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Introduction

This is the exercise set for the course “Neural Networks for Optimal Control.” The starter code for
the exercises can be found at: http://github.com/DecodEPFL/NNs-for-OC.
Before beginning the exercises, please ensure that you have all the necessary tools installed on your
computer. We will use Python, and the following packages are required:

• torch

• numpy

• matplotlib

• jax

• pip

• tqdm

Detailed installation instructions can be found in Appendix C.
Once everything is installed, run the file test installation.py. If it completes without errors, it means
that the installation was successful.

1 Control of the water level in a tank

1.1 Model description

We consider a water tank, as shown in Figure 2. The system model is given by:

A
(
x(t)

)
ẋ(t) = utot(t)− a

√
x(t), (1)

where a > 0 and A(x) is defined as A(x) = b + x with b > 0. The state x(t) represents the water level
in the tank, and the input utot(t) corresponds to the inflow of water into the tank. For this exercise, we
will use the parameter values listed in Table 2.

1.2 Objective

Our goal is to stabilize the system around a fixed water level x̄ > 0. Additionally, we aim to achieve
this as quickly as possible while minimizing energy consumption. Furthermore, we must comply with the
following physical constraints:

x(t)

utot(t)

a x(t)

Figure 1: Water tank scheme
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a 0.1
b 0.5
x̄ 0.2
h 0.1
N 200

Table 1: Parameters for the water tank system

R1 the input utot(t) should be smooth;

R2 the water inflow cannot be negative (utot(t) ≥ 0 for all t);

R3 the water level must remain within the range 0 ≤ x(t) ≤ xmax, for all t.

To achieve this, we will follow the two-step procedure introduced in the course. First, we will design a
basic pre-stabilizing controller. Then, we will implement a performance-boosting controller to tackle the
requirements R1-R3.

1.3 Exercises

1.3.1 Pre-stabilizing controller

Given a desired equilibrium x̄, a base controller that asymptotically stabilizes the tank system is
given by

utot(t) = a
√
x̄+ u(t). (2)

The dynamics of the pre-stabilized system can be written as

ẋ =
1

x+ b
(−a

√
x+ a

√
x̄+ u). (3)

1. Validate the asymptotic stability of the system by plotting the phase portrait x vs. ẋ. To do so, run
the script run validation prestab.py, which can be found in the experiments/tank/ folder.

1.3.2 System discretization

To simulate the system, we use the forward Euler integration scheme with a discretization step size
h. The discretized dynamical system is then given by:

xk+1 = xk +
h

xk + b
(−a

√
xk + a

√
x̄+ uk). (4)

We assume that the system is affected by additive process noise, meaning that (4) is subject to distur-
bances wk, leading to:

xk+1 = xk +
h

xk + b
(−a

√
xk + a

√
x̄+ uk) + wk. (5)

This noise can be interpreted as a disturbance introduced by the discretization process or as an error
due to model mismatch.

2. Simulate the pre-stabilized system starting from different initial conditions by running the script
run OL trajectories.py. Verify that the system stabilizes around x̄ when considering uk = wk =
0.

Remark 1. Note that the system is defined in the class TankSystem. Details of this class can be
found in Appendix A. To simulate the system, a controller model is created. In this case, we use
the ZeroController class, which outputs zero at all times. Then, the controller is then applied in
the TankSystem.rollout method.
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1.3.3 Performance-boosting controller

The system is now stable around x̄. However, to improve the performance of the controller, we will
design performance-boosting controllers that aim to minimize different cost functions. As described in
Section 3.2, our goal is to stabilize the system as quickly as possible while controlling the supplied energy
and complying with the physical requirements R1-R3.

3. Run the script run tank LQ.py which designs a PB controller for improving the performance of
the tank system with respect to the following quadratic cost:

L1 =

N∑
k=0

1

2
(q(x− x̄)2 + ru2), (6)

when starting from x0 = 0.1, while considering disturbances wk ∼ N (0, 0.005).

The objective of this point is to familiarize oneself with all the elements needed to train a PB
controller. In particular:

• The training procedure (a for loop that does a gradient descend step at each iteration) can
be found in the run tank LQ.py file.

• The file controllers/PB controller.py contains a PB controller implementation in the
class PerfBoostController. Note that one can choose between RENs and SSMs for a neural
network implementation of an L2 operator. Details of this class can be found in Appendix B.

• The cost function (6) to be minimized is implemented in the class TankLoss which can be
found in the file experiments/tank/loss functions.py.

Test the training for different hyperparameter weights.

4. The function TankLoss.loss smooth input, defined in experiments/tank/loss functions.py,
seeks to promote R1 by penalizing the absolute difference between two consecutive inputs. Design
and test a new controller by incorporating this cost term into the loss function of the optimization
problem.

5. To promote R2, design a barrier-like cost function that penalizes negative input flows, and use it
to design a new PB controller.

Hint 1: You can design a new method inside the TankLoss class (in loss functions.py) and add
it to the TankLoss.forward method.

Hint 2: Recall that a negative input flow implies ut < −a
√
x̄.

Hint 3: This cost function is relevant (meaningful?) when training a controller starting at x0 > x̄.
Train the controller for an initial condition that satisfies this inequality.

6. Requirement R3 states that if the initial condition of the system is within the interval [0, xmax],
the state must remain in this interval. Design and include an invariant-like cost function in the
training procedure to promote requirement R3. Test the resulting controller.

7. Bonus Exercise (if time allows): Experiment with different hyperparameters and explore alter-
native models for the L2 operator: change dimensions and activation funcitons of the State-Space
Model (SSM), use Recurrent Equilibrium Networks (REN) instead of SSMs, etc. Observe how these
changes affect the performance of the neural network controller.
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2 Control of a vehicle on the horizontal plane

We now consider a point-mass vehicle. The vehicle is described by its position pt ∈ R2 and velocity
qt ∈ R2, subject to nonlinear drag forces (e.g., air or water resistance). The discrete-time model is given
by [

pt+1

qt+1

]
=

[
pt
qt

]
+ h

[
qt

− 1
mC(qt) +

1
mFt

]
+ wt , (7)

where m > 0 is the mass of the robot, Ft ∈ R2 denotes the control input force, h > 0 is the sampling
time, wt represents an unknown disturbance affecting the system, and C : R2 → R2 is a drag function
given by

C(s) = b1s− b2 tanh(s) , (8)

for some 0 < b2 < b1.

2.1 Stability

The robot must reach the origin with zero velocity in a stable manner. This elementary goal can be
achieved using a base proportional controller:

F ′
t = −K ′(pt) , (9)

where K ′ = diag(k1, k2) and k1, k2 > 0.
The pre-stabilized system is then given by:

xt+1 = xt + h

([
0 1

−K′

m − b1
m

]
xt +

[
0

b2
m tanh(qt)

]
+

[
0
ut

])
+ wt (10)

where xt =
[
pt qt

]⊤
, and ut is the remaining input to the system, i.e. Ft = F ′

t + ut.

1. Simulate the vehicle dynamics, prior to setting the pre-stabilizing controller, i.e., with k1 = k2 = 0,
and no disturbances. Use the following input signals:

(a) A step signal for 20 steps, then zero.

(b) A sinusoidal signal for 20 steps, then zero.

The file run robot.py can be used as a template.

Hint 1: Use the rolloutmethod with a “controller” that outputs the desired ut, as per InputController
which can be found in controllers/input signal.py.

Hint 2: Use the functions plot trajectories and plot traj vs time, which can be found in the
folder experiments/robot/plot functions.py, to plot the obtained state and input trajectories.

2. Add a base controller and simulate the vehicle starting from an initial condition different from the
equilibrium point, with disturbances sampled from N (0, 0.01).

Note: Thanks to the use of the pre-stabilizing controller (9), one can show that F(u,w) ∈ L2.

2.2 Objective

The goal of the performance-boosting policy is to enforce additional desired behaviors, on top of
stability. In this exercise, we focus on avoiding collisions with an obstacle. We consider that the vehicle,
modeled as a point mass, is a circular element with radius rr, and the obstacle has a radius of robs.
Furthermore, assume that the obstacle is placed at pobs ∈ R2.

We select a loss function L(xT :0, uT :0) as the sum of stage costs l(xt, ut), that is,

l(xt, ut) = ltraj(xt, ut) + lobs(xt) , (11)

where ltraj(xt, ut) = x⊤
t Qxt+u⊤

t Rut with Q ⪰ 0 and R ≻ 0. The function ltraj penalizes the distance of
the robot to its target(s) and the amount of used energy, and lobs(xt) penalizes collisions with obstacles.
The latter is a barrier-like function:
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lobs(xt) =

{
αobs(dt + ϵ)−2 if dt ≤ Dsafe,

0 otherwise,
(12)

and where ϵ > 0, dt = |pt − pobs|2, and Dsafe = 1.2(rr + robs).

3. Implement and train a PB controller for the pre-stabilized system of point 2.

Hint 1: use the already defined PerfBoostingController class.

Hint 2: the class RobotsLoss provides some useful cost functions that can be used during the
training.

2.3 Temporal Logic formulations

In the previous exercises, we have always implemented cost functions which can be written as a
summation in time. However, we can also implement more general cost functions which do not rely on
time averaging.

In the folder experiments/robot TL, we implemented a training procedure that uses a different cost
function. This is in the form of a Truncated Linear Temporal Logic (TLTL) formulation [1, 2]. Check
the algorithm and explain why it is a possible candidate solution.
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3 System identification of an input-output water dynamical wa-
ter tank model

3.1 Model description

We consider the same water tank of the previous exercise, as shown in Figure 2, where the input
given to the system is the inflow of water needed to achieve a certain water level. More in detail, we
consider the dynamics:

ẋ =
a

x+ b
(
√
u−

√
x). (13)

The input given to the system is such that, for a constant u > 0, the system converges to u itself. Upon
discretization via forward Euler and adding an additive process noise term, we get

xk+1 = xk +
ha

xk + b
(
√
uk −

√
xk) + wk. (14)

This noise can be interpreted as a disturbance introduced by the discretization process or as an error
due to model mismatch.

x(t)

utot(t)

a x(t)

Figure 2: Water tank scheme

The system model is given by:

a 0.6
b 0.5
x̄ 0.2
h 0.1
N 200

Table 2: Parameters for the water tank system

3.2 Objective

Our goal is to identify the tank system from input/output pairs (ũ, x̃), where the output corresponds
directly to the system state, i.e., the water level in each tank. A key requirement is that the identified
model not only fits the data but also preserves the stability properties of the true system. This ensures
that the learned model remains a stable dynamical system, maintaining physically meaningful behavior
over time.

3.3 Exercises

3.3.1 Simulate the model and generate input/output pairs

We need to generate input/output pairs to create the dataset that we will use to learn the model.
The inputs should be sufficiently exciting in order to properly excite the system and allow for an effective
identification. In the script tank dataset sysid.py we find the discretized model of the tank, as well as
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functions that generate two different types of input: piecewise constant and sinusoidal ones. By running
this script, we generate a default number of 600 input/output trajectories, each of length T = 200. 400
of these will be used for training the model, while the other 200 for validation. The noise in this case is
a white Gaussian process wk ∼ N (0, 0.02). The plot will be shown by running run tank sysid.py

1. Play around with the parameters of the model and the inputs, and generate the data set that we
will use for training.
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Figure 3: Output evolution for a constant and sinusoidal input.

3.3.2 System identification

We now want to learn the tank model by fitting an L2 stable parametrized operator Mθ. More in
detail, given N training trajectories and a time horizon of T , we want to solve min

θ

1

NT

N∑
s=1

T∑
k=1

∥ỹsk − ysk∥22

s.t. ysk = Mθ(ũ
s
k:0), ∀s = 1, . . . , N

(15)

4. Find a solution for this problem (numerically) by using the generated dataset of trajectories (ũ, x̃)
and using different families of operators Mθ such as RENs, SSMs, RNNs, etc... The python code
that implements these models can be found in experiments/tanks sysid/Models sysid.py while
the training procedure is in experiments/tanks sysid/run tank sysid.py.

5. Compare the different results in terms of accuracy in training and validation and produce plots
showing how the trained model compares against validation data.

6. Try to change the hyperparameters of each operator (number of layers for SSMs etc...), start from
small models and then increase the complexity.
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A Code for tank system

The tank system is implemented in the TankSystem class, located in the file plants/tanks/tank sys.py.
This class defines the system dynamics and provides several key methods:

• TankSystem. init : This method initializes the tank system, setting its parameters (e.g., a, b,
. . . ) and defining the nominal equilibrium state.

• TankSystem.dynamics: This method computes the right-hand side of (13), which defines the sys-
tem’s continuous-time dynamics.

• TankSystem.forward: This method computes the next state of the system given its current state,
input, and process noise. It integrates the dynamics (given by the TankSystem.dynamics method)
using the forward Euler integration scheme. Note that this method is invoked automatically when
calling an instance of TankSystem (i.e., my tank(x, u, w)) because TankSystem inherits from
nn.Module, which overrides the call method to internally execute forward.

• TankSystem.rollout: This method simulates the closed-loop system over a given time horizon. It
requires a controller and a sequence of disturbances as inputs. Internally, it calls TankSystem.forward
to update the system state at each time step. It uses the TankSystem.forward method and outputs
the state and input trajectories.

Since the tank system is only defined for x ≥ 0, the TankSystem.forward method includes a satu-
ration mechanism: if the computed next state is negative, it is clipped to zero. Similarly, as the system
input must be nonnegative (utot ≥ 0), the input is filtered before being applied to the system.

B Code for performance-boosting controller

The performance-boosting controller is implemented in the PerfBoostController class, located in
the file controllers/PB controller.py. Below, we describe its main components:

• PerfBoostController. init : This method initializes the controller, setting its internal param-
eters and defining the neural network model used for the L2-stable operator. It supports two
architectures: RENs (Recurrent Equilibrium Networks) and Deep SSMs (State-Space Models). As
the controller has a copy of the system, this function requires as parameter noiseless forward

the dynamics of the dynamical system to be controlled.

• PerfBoostController.forward: This method implements one forward step of the controller. Given
an input measurement (e.g., the state of the plant), it computes the next control action. The process
follows these steps:

1. Compute the noise-free input using the noiseless forward function.

2. Reconstruct the disturbance affecting the system.

3. Pass the disturbance through the L2-stable operator (REN or SSM) to compute the control
output.

4. Update the internal states and increment the time step.

Since PerfBoostController inherits from nn.Module, calling an instance of the controller (e.g.,
my controller(input t)) automatically invokes the forward method.

• PerfBoostController.reset: This method resets the internal states of the controller, setting the
time to zero and reinitializing the stored input and output values. Additionally, it resets the internal
states of the chosen L2-stable model.

Since the controller operates in a closed-loop setting, its input corresponds to the measured state of
the plant, while its output determines the control action applied to the plant.
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C Code for robot system

The RobotsSystem class implements a dynamical system representing a robot that can move in the
horizontal plane. The vehicle has nonlinear dynamics, where the nonlinearity arises from speed-dependent
friction. Below, we describe its key components:

• RobotsSystem. init : This method initializes the robot system, by setting its parameters. Par-
ticularly, parameter k ≥ 0 is the gain of the pre-stabilizing controller. Note that setting k = 0
removes the pre-stabilizing controller.

• RobotsSystem.noiseless forward: Computes the next state of the system without process noise.
It applies the state transition model.

• RobotsSystem.forward: Implements the system dynamics, incorporating process noise. Given the
current state x, input u, and noise w, it returns the next system state.

• RobotsSystem.rollout: Simulates the system evolution over time under a given controller. The
simulation can be run in training mode (with gradient tracking) or evaluation mode (disabling
gradient tracking for efficiency).
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Installing tools for Python development

In this section, we are concerned with the Python installation, the required libraries, and the config-
uration of our development environment using PyCharm.

Note: If you are already familiar with development environments, feel free to use your preferred one
(e.g., Visual Studio Code (VS Code)). Note: If you use VS Code, you need to add the path manually.
One way to do this is by adding a base folder.pth file in venv/Lib/site-packages containing the
complete path, e.g., C:/ .../NNs-for-OC.

1. Installing Python (min 3.10)
If Python is not already installed on your computer, you can go to the official Python website and
download the installer by following the steps indicated in their website.

2. Verify the installation
Open a terminal and type:

python --version

This command should display the installed Python version (minimum Python 3.10), confirming a
successful installation.

3. Installing PyCharm as an Integrated Development Environment (IDE)
For effective coding, we recommend installing PyCharm. This IDE provides useful features such
as syntax highlighting, debugging, and version control. Please refer to its respective website for
installation instructions. Note the following instructions are tested for the Professional version.

(a) Go to the official JetBrains website: https://www.jetbrains.com/pycharm/download/.

(b) Choose the appropriate version:

• The Professional version (paid) offers advanced features.

• The Community version (free) is suitable for basic Python development.

(c) Download the installer suitable for your operating system (Windows, macOS, or Linux).

(d) Run the installer and follow the on-screen instructions.

(e) Once installed, launch PyCharm.

4. Clone the repository in a new PyCharm project
We will clone the repository that contains all the material for the exercises of this course and create
a new project.

(a) Open PyCharm.

(b) Click Git → Clone.

(c) Select Repository URL.

(d) Choose the directory where you want to clone the repository.

(e) In theURL field, paste the URL of the repository http://github.com/DecodEPFL/NNs-for-OC.

(f) Click Clone and wait for the process to complete.

(g) Once cloned, the project will open automatically in PyCharm.

5. Setting a virtual environment 1 and installing the required packages

• Automatic setting of the virtual environment.
If the IDE asks to create a virtual environment select the desired location for the virtual
environment (e.g. same folder of the project) and click ok.

1A Python environment is an isolated workspace that contains a specific Python version and a set of packages.
It allows you to manage dependencies for a project without interfering with other projects. In PyCharm, you do not
need to activate the environment manually every time you open the IDE—PyCharm automatically activates the correct
environment for your project. Moreover, once you install a package in the environment, it becomes immediately available
without the need for reactivation.
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• Manual setting of the virtual environment.
Open the PyCharm terminal.

(a) Look at the left panel of the PyCharm window.

(b) Click on View → Tool Windows → Terminal.

(c) A terminal window will appear at the bottom of the PyCharm interface.

(d) You can now execute commands just as you would in a regular command-line interface.

Run the following line:

python setup.py

Note: If python does not work, try with python3.
This creates a new virtual environment (venv) in our root folder of the project as well as
installs the required packages: numpy, matplotlib, and torch...

6. Once the installation is finished, we need to indicate PyCharm where our venv is:

(a) Click PyCharm → Settings (or File → Settings in Windows)

(b) Go to Project: NNs for OC → Python Interpreter.

(c) Click Add Interpreter→ Add Local Interpreter.. . (Note, some PyCharm versions have
a gear icon to add the interpreter)

(d) Choose Virtualenv Environment on the left.

(e) Select Existing environment and click the three dots ... to browse for your virtualenv.
Choose the Python executable from the bin (macOS) or Scripts (Windows) folder.

• Windows: NNs for OC\venv\Scripts\python.exe
• macOS \Linux: NNs for OC\venv\bin\python

Note: if you have more than one python executable try choosing the latest one. If it does not
work, try with the previous ones.

(f) Click OK or Apply to set it as your project’s interpreter.

(g) Check the bottom right corner, near a small padlock icon, to see if the project’s interpreter is
set to the correct virtual environment.

7. Test the installation.
Open and run (click the play button on the top right side of the IDE) the file:

test installation.py

If the play button is not available, navigate to View → Tool Windows → Run and then click the
run button on the left.
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